bannerslider_joomla_boeken.jpg

Joomla 2.5, Joomla 3 ... welke versie gebruiken?

De makers van Joomla zaaien verwarring: er zijn verschillende versies van het cms beschikbaar. Welke kun je het beste gebruiken als je nu een website wil bouwen?

Als je nu Joomla installeert, gebruik dan de meest recente versie van de 3-serie. Volgens planning komen daarvan jaarlijks enkele updates uit (3.4, 3.5, 3.6 enzovoort). Dat is anders dan bij Joomla 1.5 en 2.5: dat waren‘definitieve’ versies waarbij de ontwikkeling voor langere tijd stopte. Lange tijd was het de bedoeling om ook een 'definitieve' versie Joomla 3.5 te maken. Maar een definitieve versie 3.5 of een ander definitief versienummer komt er niet: als er behoefte is aan verfijningen of verbeteringen, dan verschijnt een update. Maar radicale veranderingen komen er niet: die zijn pas weer mogelijk vanaf versie 4.

Het voordeel van deze contine updates is dat je als gebruiker profiteert van verbeteringen, zonder dat je moet leren werken met een volledig nieuwe versie. Bovendien is updaten naar een hogere versie een kwestie van een paar klikken.

De Basiscursus Joomla 3 Herziene Editie en Tips en tools voor Joomla 3 zijn gebaseerd op versie 3.3. Als er daarna belangrijke veranderingen komen hogere versies van Joomla 3, dan vind je die updates op deze site.

Wanneer kies je voor Joomla 2.5?

Op dit moment kun je ook de oude versie 2.5 nog downloaden. Die wordt nog altijd ondersteund met veiligheidsupdates. Maar het is wel een oude versie, die je alleen nog gebruikt als je bepaalde uitbreidingen nodig hebt die alleen geschikt zijn voor die versie. Dat zijn er minder en minder - en dus is er alle reden om over te stappen naar de nieuwste generatie, Joomla 3.